
 

PHOTOSHOP 

Basic (1-25) 

1.​ What is Adobe Photoshop?​
 

○​ Adobe Photoshop is a powerful raster graphics editor used for photo editing, 
digital painting, and creating designs with pixel-based imagery.​
 

2.​ What is the difference between a raster image and a vector image?​
 

○​ Raster images are made up of pixels, and resizing them can lead to quality 
loss. Vector images are made of paths and can be scaled infinitely without 
losing quality.​
 

3.​ What is the purpose of the Layers panel in Photoshop?​
 

○​ The Layers panel allows you to manage different elements of a composition 
separately, making it easier to edit and organize your work.​
 

4.​ How do you create a new document in Photoshop?​
 

○​ Go to File > New or press Ctrl+N (Windows) or Cmd+N (Mac) to create a 
new document.​
 

5.​ What are the different types of selection tools in Photoshop?​
 

○​ Selection tools include the Marquee tool, Lasso tool, Magic Wand tool, and 
Quick Selection tool, each serving different selection needs.​
 

6.​ How do you resize an image in Photoshop?​
 

○​ Use the Image > Image Size menu or press Ctrl+Alt+I (Windows) or 
Cmd+Option+I (Mac) to adjust the image dimensions.​
 

7.​ What is the use of the Clone Stamp tool?​
 

○​ The Clone Stamp tool is used to duplicate pixels from one area of the image 
and paint them over another area.​
 

8.​ How do you undo an action in Photoshop?​
 

○​ You can undo an action by pressing Ctrl+Z (Windows) or Cmd+Z (Mac). You 
can also go to Edit > Undo.​
 



 

9.​ What is the difference between the Healing Brush and the Clone Stamp tool?​
 

○​ The Healing Brush blends the cloned area with the surrounding pixels to 
match texture, while the Clone Stamp tool simply copies the exact pixels.​
 

10.​What is the Layers palette in Photoshop?​
 

○​ The Layers palette displays all the layers in an image, and it allows users to 
control the visibility, order, and properties of each layer.​
 

11.​What are adjustment layers in Photoshop?​
 

○​ Adjustment layers are non-destructive layers that allow you to apply color and 
tonal adjustments to your image without permanently altering the image itself.​
 

12.​What is the purpose of the Magic Wand tool?​
 

○​ The Magic Wand tool selects areas of similar color in the image, making it 
easier to isolate portions for editing.​
 

13.​How do you crop an image in Photoshop?​
 

○​ Use the Crop Tool from the toolbar, or go to Image > Crop to trim excess 
parts of the image.​
 

14.​What is the difference between the Move tool and the Selection tool in 
Photoshop?​
 

○​ The Move tool is used to move selected elements, while the Selection tool is 
used to select portions of the image.​
 

15.​What are smart objects in Photoshop?​
 

○​ Smart objects are layers that contain image data from raster or vector 
images. You can perform non-destructive transformations and edits on them.​
 

16.​How do you add text to an image in Photoshop?​
 

○​ Use the Text Tool (T) to click on the canvas and type text.​
 

17.​What is the use of the Eraser tool in Photoshop?​
 

○​ The Eraser tool is used to delete pixels from a layer, effectively erasing parts 
of the image.​
 

18.​What is a layer mask?​
 



 

○​ A layer mask allows you to hide or reveal parts of a layer without permanently 
deleting any content.​
 

19.​How do you create a gradient in Photoshop?​
 

○​ Use the Gradient Tool (G) and select a gradient preset from the gradient bar, 
or create a custom gradient using the Gradient Editor.​
 

20.​What is the Quick Selection tool used for?​
 

○​ The Quick Selection tool allows you to quickly paint a selection over an image 
based on color and texture similarity.​
 

21.​What is the difference between RGB and CMYK color modes in Photoshop?​
 

○​ RGB is used for digital displays and is based on light (Red, Green, Blue), 
while CMYK is used for printing and is based on ink (Cyan, Magenta, Yellow, 
Key/Black).​
 

22.​How do you change the color of an object in Photoshop?​
 

○​ Use the Hue/Saturation adjustment layer, or use the Color 
Replacement Tool to change the color of specific areas.​
 

23.​What is the purpose of the Blur tool in Photoshop?​
 

○​ The Blur tool softens the edges of an image, reducing sharpness and details.​
 

24.​What is the difference between the Gradient Map and the regular Gradient tool?​
 

○​ The Gradient Map applies a gradient based on the tonal range of the image, 
while the Gradient tool applies a gradient directly to an object or selection.​
 

25.​What are filters in Photoshop?​
 

○​ Filters in Photoshop are used to apply special effects to an image, such as 
blurring, sharpening, or artistic effects.​
 

 

Intermediate (26-50) 

26.​How do you convert a color image to black and white in Photoshop?​
 



 

○​ You can convert an image to black and white by using an Adjustment 
Layer and selecting Black & White.​
 

27.​What is the Content-Aware Fill tool used for?​
 

○​ The Content-Aware Fill tool automatically fills selected areas by blending 
them with the surrounding content in the image.​
 

28.​What is the difference between a regular layer and an adjustment layer in 
Photoshop?​
 

○​ Regular layers contain actual image data, while adjustment layers apply 
non-destructive edits to the underlying layers.​
 

29.​How do you create a clipping mask in Photoshop?​
 

○​ Right-click on the layer and select Create Clipping Mask, or press 
Alt+Ctrl+G (Windows) or Option+Cmd+G (Mac).​
 

30.​How do you remove a background from an image in Photoshop?​
 

○​ Use the Magic Wand Tool, Quick Selection Tool, or the Select 
and Mask workspace to isolate the subject and remove the background.​
 

31.​What is the purpose of the Path Selection tool in Photoshop?​
 

○​ The Path Selection tool allows you to move and manipulate entire paths or 
vector shapes within a Photoshop document.​
 

32.​What is the purpose of the History panel in Photoshop?​
 

○​ The History panel tracks all your actions and allows you to revert to a 
previous state in your work.​
 

33.​How do you create a shadow effect in Photoshop?​
 

○​ You can create a shadow by duplicating the object, filling it with a darker color, 
and applying a Gaussian Blur effect, or by using the Layer Style > Drop 
Shadow.​
 

34.​What is the purpose of the Content-Aware Move tool in Photoshop?​
 

○​ The Content-Aware Move tool allows you to move an object within an image 
and automatically fill in the background where the object was previously 
located.​
 



 

35.​How do you apply a vignette effect in Photoshop?​
 

○​ Create a new layer, fill it with black, and then apply a radial gradient with the 
center transparent to achieve a vignette effect.​
 

36.​How do you use the Pen tool in Photoshop?​
 

○​ The Pen tool is used to create vector paths, which can be converted into 
selections, masks, or filled with color.​
 

37.​What is the difference between the Healing Brush and the Spot Healing Brush 
tool?​
 

○​ The Healing Brush allows you to manually select a source area to heal from, 
while the Spot Healing Brush automatically chooses the source area.​
 

38.​How do you create a transparent background in Photoshop?​
 

○​ To create a transparent background, delete or hide the background layer and 
save the file in a format that supports transparency, such as PNG.​
 

39.​How do you combine multiple images into one in Photoshop?​
 

○​ Open all images as layers in a single document and position them using the 
Move tool.​
 

40.​What is a smart filter in Photoshop?​
 

○​ A Smart Filter is a non-destructive filter applied to a Smart Object, allowing 
you to modify or remove the filter at any time.​
 

41.​How do you use layer styles in Photoshop?​
 

○​ Layer styles can be accessed via the Layer menu > Layer Style, where 
you can add effects like shadows, glows, and bevels to your layers.​
 

42.​How do you use the Puppet Warp tool in Photoshop?​
 

○​ The Puppet Warp tool allows you to manipulate parts of an image by placing 
pins on it, which act as control points to deform the image.​
 

43.​How do you sharpen an image in Photoshop?​
 

○​ You can sharpen an image by using filters such as Unsharp Mask or Smart 
Sharpen under the Filter > Sharpen menu.​
 



 

44.​How do you create a panorama in Photoshop?​
 

○​ Use the Photomerge function found under File > Automate to combine 
multiple images into a panorama.​
 

45.​What is the difference between the Dodge tool and the Burn tool?​
 

○​ The Dodge tool lightens areas of an image, while the Burn tool darkens them.​
 

46.​What is the use of the Adjustment Layers panel?​
 

○​ The Adjustment Layers panel allows you to make non-destructive color and 
tonal adjustments, such as brightness, contrast, and hue.​
 

47.​How do you apply a gradient map in Photoshop?​
 

○​ Gradient maps are applied via Image > Adjustments > Gradient Map, 
which maps the gradient onto the image’s tonal range.​
 

48.​How do you remove dust or scratches from an image in Photoshop?​
 

○​ Use the Dust & Scratches filter or the Spot Healing Brush to remove 
imperfections from the image.​
 

49.​What is the use of the Ruler tool in Photoshop?​
 

○​ The Ruler tool is used to measure distances and angles in an image, helpful 
for tasks requiring precise alignment.​
 

50.​How do you add a texture overlay in Photoshop?​
 

○​ Place the texture image on a new layer and set its blending mode to 
something like Overlay or Soft Light to integrate it into the original 
image.​
 

 

Advanced (51-75) 

51.​What is a vector mask in Photoshop?​
 

○​ A vector mask is a scalable path that can be used to hide or reveal parts of a 
layer, similar to a layer mask, but it uses vector shapes.​
 

52.​How do you simulate depth of field in Photoshop?​
 



 

○​ Use the Lens Blur filter or the Field Blur filter to simulate a shallow 
depth of field in an image.​
 

53.​What is the use of the Camera Raw filter in Photoshop?​
 

○​ The Camera Raw filter allows you to make detailed adjustments to raw 
images, such as exposure, contrast, and sharpness, after they have been 
imported.​
 

54.​How do you use the Liquify filter in Photoshop?​
 

○​ The Liquify filter allows you to push, pull, rotate, or distort areas of the image, 
which is useful for retouching and artistic effects.​
 

55.​What is the purpose of the 3D tools in Photoshop?​
 

○​ Photoshop’s 3D tools allow you to create 3D objects, apply textures, and 
render 3D graphics.​
 

56.​How do you create a custom brush in Photoshop?​
 

- To create a custom brush, select an image or texture, go to `Edit` > `Define Brush Preset`, 
and save it as a new brush. 
 

57. What is the difference between RGB and Lab color modes in Photoshop? - Lab 
color mode uses three color channels—L for lightness, a for green to red, and b for blue to 
yellow—providing more flexibility for color manipulation. 

58.​How do you use the Blur Gallery in Photoshop?​
 

○​ The Blur Gallery allows you to create various blur effects such as field blur, 
path blur, and tilt-shift using an intuitive interface.​
 

59.​What is the function of the Feather option in Photoshop?​
 

○​ Feathering softens the edges of a selection, creating a gradual transition 
between the selected area and the background.​
 

60.​How do you create a double exposure effect in Photoshop?​
 

○​ Use layer blending modes and masks to combine two images creatively, 
allowing one image to blend into another.​
 

61.​What is a 3D extrusion in Photoshop?​
 



 

○​ A 3D extrusion converts vector artwork into a 3D object that can be rotated 
and manipulated in 3D space.​
 

62.​How do you create a mockup in Photoshop?​
 

○​ To create a mockup, import your design into a template or smart object, and 
use smart filters and layer styles to place it on a product or device.​
 

63.​How do you create a displacement map in Photoshop?​
 

○​ A displacement map uses a grayscale image to create a realistic effect, 
distorting your base image based on the lightness values of the map.​
 

64.​What is the difference between 8-bit and 16-bit color depth?​
 

○​ 16-bit images offer a higher dynamic range, allowing for finer gradients and 
smoother tonal transitions compared to 8-bit images.​
 

65.​How do you match colors in Photoshop?​
 

○​ You can match colors using the Match Color command, which adjusts the 
color balance to match another image.​
 

66.​How do you restore missing pixels in a photo in Photoshop?​
 

○​ You can restore missing pixels using the Content-Aware Fill or the 
Clone Stamp tool to fill in gaps in an image.​
 

67.​How do you make an animated GIF in Photoshop?​
 

○​ Create multiple layers with each frame of your animation and then use the 
Timeline panel to set the frame duration and create a GIF.​
 

68.​What is the importance of the Path panel in Photoshop?​
 

○​ The Path panel allows you to create, edit, and manage paths for 
vector-based designs or selections.​
 

69.​How do you use the Selective Color adjustment layer in Photoshop?​
 

○​ Selective Color allows you to adjust the individual color components of an 
image (cyan, magenta, yellow, and black) for precise color corrections.​
 

70.​How do you simulate a tilt-shift effect in Photoshop?​
 



 

○​ Use the Field Blur from the Blur Gallery to simulate a shallow depth of 
field and create a tilt-shift effect.​
 

71.​What is the difference between using a mask and a selection in Photoshop?​
 

○​ A mask is non-destructive and can be adjusted at any time, while a selection 
is temporary and needs to be re-created for further edits.​
 

72.​How do you create a photorealistic composite in Photoshop?​
 

○​ Carefully match lighting, shadows, and perspective using layer adjustments, 
masks, and color correction techniques to seamlessly combine multiple 
images.​
 

73.​What is an Artboard in Photoshop?​
 

○​ An Artboard is a feature used for creating multiple layouts or designs within 
the same document, often used in UI/UX design.​
 

74.​How do you create a high-key or low-key image in Photoshop?​
 

○​ Adjust the exposure, brightness, and contrast using adjustment layers to 
emphasize highlights (high-key) or shadows (low-key).​
 

75.​How do you use frequency separation for skin retouching?​
 

○​ Frequency separation is a technique that separates the texture and color of 
the skin into two layers, allowing for detailed retouching without affecting 
texture.​
 

 

Technical (76-100) 

76.​What is the purpose of the Photoshop API?​
 

○​ The Photoshop API allows developers to automate and integrate Photoshop 
features into custom workflows and applications.​
 

77.​How do you integrate Photoshop with Adobe Bridge?​
 

○​ Photoshop integrates with Adobe Bridge to streamline image organization 
and workflow. You can open, edit, and manage files directly from Bridge.​
 

78.​What is the significance of the Render function in Photoshop?​
 



 

○​ Rendering in Photoshop refers to generating high-quality images, especially 
in 3D environments, or applying effects that require computation.​
 

79.​How do you fix banding in an image in Photoshop?​
 

○​ Banding can be reduced by working in 16-bit mode, using the Noise filter to 
add subtle noise, or adjusting the gradient smoothness.​
 

80.​How do you automate tasks in Photoshop?​
 

○​ You can automate tasks using actions, scripts, or batch processing to apply 
the same adjustments to multiple files.​
 

81.​What are the performance benefits of using Smart Objects in Photoshop?​
 

○​ Smart Objects preserve the original quality of images and allow 
non-destructive transformations, which can improve performance by reducing 
the need for constant re-editing.​
 

82.​How do you optimize Photoshop for better performance?​
 

○​ Adjust Photoshop’s performance settings under Preferences > 
Performance, including increasing memory usage, optimizing scratch disks, 
and adjusting cache levels.​
 

83.​What is the significance of the Scripting feature in Photoshop?​
 

○​ Scripting in Photoshop allows for automation and advanced manipulation of 
the software through JavaScript, AppleScript, or VBScript.​
 

84.​How do you troubleshoot Photoshop when it runs slowly?​
 

○​ Check available system resources, disable unnecessary plugins, clear the 
cache, or adjust the preferences to optimize performance.​
 

85.​How do you use external plugins with Photoshop?​
 

○​ Install third-party plugins through the Plugins menu or the Preferences 
settings, which can add functionality like special effects or retouching tools.​
 

86.​What are the different ways to color correct an image in Photoshop?​
 

○​ Use adjustment layers like Curves, Levels, Color Balance, and 
Selective Color to correct color issues in an image.​
 

87.​What is the benefit of using 32-bit color depth in Photoshop?​
 



 

○​ 32-bit color depth allows for greater precision and more color data, enabling 
HDR (High Dynamic Range) workflows for better image quality.​
 

88.​How do you fix pixelation in Photoshop?​
 

○​ Pixelation can be reduced by increasing the resolution of the image or using 
interpolation methods during resizing, like Bicubic Smoother.​
 

89.​What is the difference between the Indexed Color and RGB Color modes in 
Photoshop?​
 

○​ Indexed Color uses a limited color palette suitable for web images, while RGB 
allows for a wider range of colors, especially for print.​
 

90.​What is the Save for Web feature in Photoshop?​
 

○​ The Save for Web feature optimizes images for online use by reducing file 
size without losing significant quality, supporting formats like PNG, JPEG, and 
GIF.​
 

91.​What is the difference between Save As and Export in Photoshop?​
 

○​ Save As creates a new file or changes the file format, while Export allows 
you to save multiple versions or automate the process with presets.​
 

92.​How do you use Photoshop’s CMYK color mode for printing?​
 

○​ Use Image > Mode > CMYK Color to convert your image into the CMYK 
mode, which is suitable for print production.​
 

93.​How do you ensure color accuracy between Photoshop and a printer?​
 

○​ Calibrate your monitor, use color profiles that match your printer, and ensure 
you are working in the correct color space (e.g., RGB for screens, CMYK for 
printing).​
 

94.​What are Photoshop's performance settings, and how can you adjust them?​
 

○​ Photoshop’s performance settings can be adjusted to allocate more memory, 
enable GPU acceleration, and manage cache settings for better efficiency.​
 

95.​How do you work with HDR images in Photoshop?​
 

○​ Photoshop has specific tools for HDR image processing, such as Merge to 
HDR Pro, which blends multiple exposures into a single image with extended 



 

dynamic range.​
 

96.​How do you create a seamless pattern in Photoshop?​
 

○​ Select an area of the image, then use the Define Pattern option from the 
Edit menu to create a seamless pattern that can be used in any project.​
 

97.​What is the benefit of working in Lab color mode in Photoshop?​
 

○​ Lab color mode separates lightness from color, allowing for more precise 
adjustments, particularly for tasks like color grading and retouching.​
 

98.​What are Photoshop scripts, and how do they improve workflow?​
 

○​ Photoshop scripts are used to automate repetitive tasks, allowing for complex 
tasks to be executed automatically without manual intervention.​
 

99.​How do you use Photoshop in a multi-user environment?​
 

○​ Set up Photoshop with networked files or use Adobe Creative Cloud Libraries 
to share assets and sync preferences across multiple users.​
 

100.​ How do you restore default preferences in Photoshop? - To restore default 
preferences, press Ctrl+Alt+Shift (Windows) or Cmd+Option+Shift (Mac) 
while launching Photoshop.​
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